Open source software for numerical computation

Skip to main content

System Requirements

Scilab 6.0.0

System Requirements: Windows®

OS
  • Windows Vista (32 and 64 bits)
  • Windows 7 (32 and 64 bits)
  • Windows 8 (32 and 64 bits)
  • Windows 10 (32 and 64 bits)
Hardware
  • Pentium IV class (or equivalent) with SSE2 instructions is required
  • 2 GB RAM (1 GB minimum)
  • 600 MB hard disk space
Optional
  • An Internet connection for ATOMS modules install (using a proxy requires manual configuration of ATOMS)
  • A C compiler (Visual Studio 2010 or Visual Express 2010) for C or C++ external modules compilation and for Modelica use in Xcos

System Requirements: GNU/Linux

OS
  • Redhat 5,6,7 (32 and 64 bits)
  • CentOS 5,6,7 (32 and 64 bits)
  • Debian 8 (32 and 64 bits)
  • Ubuntu 14.04, 16.04, 16.10 (32 and 64 bits)
  • Fedora 24, 25 (32 and 64 bits)
  • ….
Hardware
  • Pentium IV class (or equivalent) with SSE2 instructions is required
  • 2 GB RAM (1 GB minimum)
  • 550 MB hard disk space
Optional
  • An Internet connection for ATOMS modules install (using a proxy requires manual configuration of ATOMS)
  • A C compiler (gcc/clang) for C or C++ external modules compilation and for Modelica use in Xcos
  • A Fortran compiler (gfortran) for Fortran external modules compilation

System Requirements: Mac OS®

OS
  • Mac OS X 10.8 (Mountain Lion®)
  • Mac OS X 10.9 (Mavericks®)
  • Mac OS X 10.10 (Yosemite®)
  • Mac OS X 10.11 (El Capitan®)
  • Mac OS X Sierra®
Software
Hardware
  • Mac Intel 64 bits processor
  • 2 GB RAM (1 GB minimum)
  • 500 MB hard disk space
Optional
  • An Internet connection for ATOMS modules install (using a proxy requires manual configuration of ATOMS)
  • A C compiler (gcc/clang) for C or C++ external modules compilation and for Modelica use in Xcos
  • A Fortran compiler (gfortran) for Fortran external modules compilation

And also

Consult the Scilab version history to check prior compatibilities